Conda Python APIΒΆ

As of conda 4.4, conda can be installed in any environment, not just environments with names starting with _ (underscore). That change was made, in part, so that conda can be used as a Python library.

There are three supported public modules. We support:

  1. import conda.cli.python_api

  2. import conda.api

  3. import conda.exports

The first two should have very long-term stability. The third is guaranteed to be stable throughout the lifetime of a feature release series--i.e. minor version number.

As of conda 4.5, we do not support pip install conda. However, we are considering that as a supported bootstrap method in the future.